home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / x11-libs / ewl-9999 / ewl-9999.ebuild < prev    next >
Text File  |  2006-01-09  |  741b  |  32 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/x11-libs/ewl/ewl-9999.ebuild,v 1.8 2005/10/20 05:38:47 vapier Exp $
  4.  
  5. inherit enlightenment
  6.  
  7. DESCRIPTION="simple-to-use general purpose widget library"
  8.  
  9. IUSE="X fbcon opengl"
  10.  
  11. DEPEND=">=media-libs/edje-0.5.0
  12.     >=dev-db/edb-1.0.5
  13.     >=x11-libs/evas-0.9.9
  14.     >=x11-libs/ecore-0.9.9"
  15.  
  16. pkg_setup() {
  17.     if ! built_with_use media-libs/edje png ; then
  18.         eerror "Re-emerge edje with USE=png"
  19.         die "Re-emerge edje with USE=png"
  20.     fi
  21.     enlightenment_pkg_setup
  22. }
  23.  
  24. src_compile() {
  25.     export MY_ECONF="
  26.         $(use_enable X software-x11)
  27.         $(use_enable opengl opengl-x11)
  28.         $(use_enable fbcon)
  29.     "
  30.     enlightenment_src_compile
  31. }
  32.